Email deliveries temporarily paused
Incident Report for Mechanic
Resolved
Our email provider has resumed email sending. All emails will be processed in the order they were received. Thank you so much for your patience.
Posted Nov 04, 2024 - 18:12 UTC
Identified
We just received a heads up from Postmark (Mechanic's email provider) that deliveries have been paused. We're on it!

⭐️ All emails are enqueued on Postmark's end, and will be delivered when Postmark hits the resume button on their end.
Posted Nov 04, 2024 - 14:48 UTC
This incident affected: Mechanic.