Degraded service
Incident Report for Mechanic
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 21:28 UTC
Update
Mechanic runtime performance is back to normal. Some stores are experiencing increased RTT times, due to store-specific Mechanic queues processing backlog from the incident period. These queues will recover normally, but please do email team@usemechanic.com if you've got questions. :)

We'll close this incident when Fly marks the incident closed on their end.

https://status.flyio.net/incidents/rw331zwl0rwp
Posted Apr 24, 2024 - 20:00 UTC
Monitoring
"A fix has been implemented and we are monitoring the results." -Fly

https://status.flyio.net/incidents/rw331zwl0rwp
Posted Apr 24, 2024 - 19:25 UTC
Update
For clarity: Mechanic event ingress is unaffected, including submissions sent to https://webhooks.mechanic.dev/.

The Mechanic platform is still accepting all submitted events, and all events will be processed as soon as the Mechanic runtime is able to address them.
Posted Apr 24, 2024 - 19:03 UTC
Update
Our infra provider has acknowledged the issue, and it's in their hands now:

https://status.flyio.net/incidents/rw331zwl0rwp
Posted Apr 24, 2024 - 18:59 UTC
Identified
The Mechanic runtime is impacted by network issues occurring upstream. It appears to be at the level of our primary infrastructure provider; we're connecting with them to see what's what.
Posted Apr 24, 2024 - 18:54 UTC
This incident affected: Mechanic.