Email deliveries temporarily paused
Incident Report for Mechanic
Resolved
Our email provider has resumed email sending. All emails will be processed in the order they were received. Thank you for your patience.
Posted Nov 05, 2024 - 16:46 UTC
Identified
We just received a heads up from Postmark (Mechanic's email provider) that deliveries have been paused. We're on it!

⭐️ All emails are enqueued on Postmark's end, and will be delivered when Postmark hits the resume button on their end.

👁️ Attentive observers will note that this is the second time this has happened in a single two-day span. Postmark's responding to an abusive user, and the platform itself is temporarily caught in the cross-fire. We're designing away the *possibility* of this kind of abuse, so that it can't happen again. :) Postmark's responsiveness here is an important part of what lets them keep email deliverability reliable, and I'm glad to be working with them on this. They're an excellent platform partner.

I'm sorry for the trouble. We're on it. 🤲

If you've got questions, we're here! team@usemechanic.com and https://slack.mechanic.dev/

All the best,

=Isaac
Posted Nov 05, 2024 - 16:36 UTC
This incident affected: Mechanic.