In-app link errors

Incident Report for Mechanic

Resolved

Resolved! My thanks to our community Slack workspace for prompting/inspiring a workaround that let us resolve this without Shopify taking action. :)

Join our Slack here: https://slack.mechanic.dev/

The specific thread: https://usemechanic.slack.com/archives/CURE65U2W/p1772059037547389
Posted Feb 25, 2026 - 23:40 UTC

Monitoring

Shopify seems to be having an issue supporting in-app links at the moment. If you're being redirected to in-app URLs ending in `/[object%20Object]`, try cmd+click or shift+click to open links in a new tab or window. :) I expect Shopify will get this resolved soon.
Posted Feb 25, 2026 - 20:42 UTC
This incident affected: Mechanic.