Display-only delay for events

Incident Report for Mechanic

Resolved

Sorted. :)
Posted Jul 21, 2026 - 14:31 UTC

Identified

In-app event lists and searches are reflecting laggy data; the issue is precisely identified, am getting it sorted.

(The event runtime/pipeline is unaffected.)
Posted Jul 21, 2026 - 00:36 UTC
This incident affected: Mechanic.