UI Performance issues

Incident Report for Mechanic

Resolved

Everything looks good now! Thanks for your patience :)
Posted Jun 11, 2026 - 20:31 UTC

Identified

The issue has been identified and we are deploying a fix.
Posted Jun 11, 2026 - 20:01 UTC

Investigating

We have reports of users experiencing issues with the Mechanic user interface. All events and tasks continue to process normally. We will update shortly!
Posted Jun 11, 2026 - 19:53 UTC
This incident affected: Mechanic.