Filtered in-app event lists are lagging

Incident Report for Mechanic

Resolved

Event filtering is caught up!

We’ve implemented a fix designed to prevent this issue from recurring in the future.

Thank you for your patience and understanding while we worked through this.
Posted Jun 16, 2026 - 16:52 UTC

Monitoring

All events continue to be processed normally. Event filtering is progressing as expected and should be fully caught up within the next three hours.

We’ve also implemented a fix designed to prevent this issue from recurring in the future.

Thank you for your patience and understanding while we worked through this.
Posted Jun 16, 2026 - 12:35 UTC

Identified

Filtered in-app event lists (e.g. event searches, events filtered by task id, etc) are lagging, producing results that do not reflect the realtime status of the actual underlying events. We are working through the backlog now,.

For clarity: events *are being processed* at a normal throughput, but their reflection in filtered event lists is l
Posted Jun 15, 2026 - 22:18 UTC
This incident affected: Mechanic.