Intermittent app availability issues

Incident Report for Mechanic

Resolved

☺️✅
Posted May 15, 2026 - 04:36 UTC

Identified

Handled; still examining it though. =Isaac
Posted May 14, 2026 - 15:34 UTC

Investigating

We're seeing the web frontend of Mechanic struggling a bit. The event pipeline is sound, backend performance is normal, but the Shopify admin app (and other requests to usemechanic.com) are currently unreliable. Am digging. 🕵 🔍 =Isaac
Posted May 14, 2026 - 14:55 UTC
This incident affected: Mechanic.