Platform outage
Incident Report for Mechanic
Resolved
This incident has been resolved.
Posted Apr 06, 2023 - 23:14 UTC
Update
The app interface is available. Mechanic's run system remains uninterrupted.
Posted Apr 06, 2023 - 22:47 UTC
Update
The app interface is once again unavailable. We're on it.
Posted Apr 06, 2023 - 22:40 UTC
Monitoring
Our application hosting provider has acknowledged the issue, and has stated that it is resolved.

https://status.heroku.com/incidents/2531

We are monitoring, and are adjusting our infrastructure dependencies accordingly.
Posted Apr 06, 2023 - 22:32 UTC
Update
The merchant-facing UI is back online.
Posted Apr 06, 2023 - 22:23 UTC
Identified
The platform is recovering. Further investigation reveals that Mechanic's runtime appears to have been uninterrupted; this appears to have been a state failure at the level of our application hosting provider.

The merchant-facing app remains offline.
Posted Apr 06, 2023 - 21:40 UTC
Investigating
The Mechanic platform is currently interrupted. Incoming Shopify events (and events from webhooks.mechanic.dev) are enqueued, and will be processed when this incident is resolved. We're investigating.
Posted Apr 06, 2023 - 21:28 UTC
This incident affected: Mechanic.