Running a maintenance; bit of a slow-down

Incident Report for Mechanic

Resolved

All done. :) 👋
Posted Jun 07, 2025 - 19:35 UTC

Monitoring

We're running a controlled database maintenance. Mechanic remains fully operational across all surfaces, just might be a bit slower here and there.
Posted Jun 07, 2025 - 15:51 UTC
This incident affected: Mechanic.