Issues with upstream DNS provider
Incident Report for Mechanic
Resolved
This incident has been resolved. See https://status.heroku.com/incidents/2453 for more details.
Posted Aug 24, 2022 - 03:43 UTC
Update
We have not received any reports of impacted webhooks. If you find that your usemechanic.com webhook is impacted, migrate your client request URLs from https://usemechanic.com/webhook/xyz to https://webhooks.mechanic.dev/xyz.
Posted Aug 24, 2022 - 00:24 UTC
Identified
Our hosting provider Heroku is having DNS issues (https://status.heroku.com/incidents/2453), impacting DNS resolution for usemechanic.com, tasks.mechanic.dev, and ui.mechanic.dev. This means that Mechanic's Shopify app interface and the task library may be unavailable to some users, and means that webhooks sent to usemechanic.com may fail delivery. Webhooks sent to webhooks.mechanic.dev are not impacted.

At this current time, all Mechanic tasks continue to run normally, and Shopify events are being delivered and processed normally.

You can follow the conversation in our Slack workspace here: https://usemechanic.slack.com/archives/CURE65U2W/p1661298446950189
Posted Aug 24, 2022 - 00:15 UTC