Filtered in-app event lists are lagging

Incident Report for Mechanic

Resolved

This incident has been resolved.
Posted Jun 05, 2026 - 15:36 UTC

Identified

Filtered in-app event lists (e.g. event searches, events filtered by task id, etc) are lagging, producing results that do not reflect the realtime status of the actual underlying events. We are working through the backlog now,.

For clarity: events *are being processed* at a normal throughput, but their reflection in filtered event lists is lagging.
Posted Jun 04, 2026 - 19:01 UTC
This incident affected: Mechanic.