Incoming events are delayed
Incident Report for Mechanic
Resolved
This incident is resolved. Impact time is 12:27 to 13:23 UTC.
Posted Aug 31, 2023 - 13:28 UTC
Monitoring
Event latency is now back to normal levels. We'll continue to monitor.

Note that this incident is scoped to incoming new events from sources outside of Mechanic. This incident did not impact events initiated by users within the app (i.e. mechanic/user/trigger events), nor did it impact scheduled events (i.e. mechanic/scheduler/*, or any runs already in the system).
Posted Aug 31, 2023 - 13:25 UTC
Identified
The issue has been identified, and we're working on remediation.
Posted Aug 31, 2023 - 13:18 UTC
Investigating
Incoming events (from Shopify, from webhooks.mechanic.dev, and from other third-party event providers) are experiencing a delay. We're investigating.

For current data on Shopify event delays, please see: https://status.mechanic.dev/#system-metrics
Posted Aug 31, 2023 - 13:07 UTC
This incident affected: Mechanic.