App availability issue

Incident Report for Mechanic

Resolved

We're back! The folks upstream located and resolved the issue. ✅
Posted May 17, 2026 - 16:01 UTC

Identified

Am working with our infrastructure and networking provider; they've located the issue on their end, and are working through it.
Posted May 17, 2026 - 15:53 UTC

Investigating

Mechanic's Shopify admin app is currently unavailable, as are other requests to usemechanic.com. (This feels like an echo of https://status.mechanic.dev/incidents/9lllghvw3tjh.) Am digging.

Meanwhile, the run pipeline is healthy; events and their tasks are being processed normally.
Posted May 17, 2026 - 15:22 UTC
This incident affected: Mechanic.